KiXforms Forum Index KiXforms
The Forum for the KiXforms Community
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 Quick Links 
Site News
Downloads
Documentation
Donations
Script Archive
Tracking Systems

Logonscript in KF.NET starts slooooooow

 
Post new topic   Reply to topic    KiXforms Forum Index -> KiXforms.NET Discussion
View previous topic :: View next topic  
Author Message
Mart
KiXforms Regular
KiXforms Regular


Joined: 03 Oct 2005
Posts: 57
Location: Rotterdam - Netherlands

PostPosted: Thu Aug 09, 2007 8:27 pm    Post subject: Logonscript in KF.NET starts slooooooow Reply with quote

I first posted this on http://www.kixtart.org/forums/ubbthreads.php?ubb=showflat&Number=179016&page=1#Post179016 because all I got when posting here were 404's but it seems that that is fixed somehow. So here we go.


The GUI of our logon script is written in KF.NET. Recently we started to implement it in a small part of our company to see how it performs and if the users have wishes/comments.

One comment that they have is that starting the script is slow. The script I used at my previous office was done in KF classic and seems to start way faster even though it has a lot more graphical stuff going on.

Is this a .NET thing? Is anybody else experiencing the same?

_________________
Mart

- He's chained forever to a world that's departed.....It's not enough, it's not enough - Sorrow by Pink Floyd.
Back to top
View user's profile Send private message
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Thu Aug 09, 2007 9:40 pm    Post subject: Reply with quote

Its a .NET thing ... the first instance of a .Net app takes forever to launch. Not so bad afterwards. For login scripts (which would always be the first thing to be run) I would stick with classic.
Back to top
View user's profile Send private message
Rod
KiXforms Webmaster
KiXforms Webmaster


Joined: 22 Feb 2003
Posts: 202
Location: United Kingdom

PostPosted: Fri Aug 10, 2007 2:25 pm    Post subject: Re: Logonscript in KF.NET starts slooooooow Reply with quote

Mart wrote:
I first posted this on http://www.kixtart.org/forums/ubbthreads.php?ubb=showflat&Number=179016&page=1#Post179016 because all I got when posting here were 404's but it seems that that is fixed somehow. So here we go.


I have no idea what that was about, plus I haven't changed anything server side for weeks. Maybe the PHP services on the server were having a mad moment.

Rod.

_________________
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Mart
KiXforms Regular
KiXforms Regular


Joined: 03 Oct 2005
Posts: 57
Location: Rotterdam - Netherlands

PostPosted: Fri Aug 10, 2007 2:51 pm    Post subject: Re: Logonscript in KF.NET starts slooooooow Reply with quote

Rod wrote:
Mart wrote:
I first posted this on http://www.kixtart.org/forums/ubbthreads.php?ubb=showflat&Number=179016&page=1#Post179016 because all I got when posting here were 404's but it seems that that is fixed somehow. So here we go.


I have no idea what that was about, plus I haven't changed anything server side for weeks. Maybe the PHP services on the server were having a mad moment.

Rod.


Dunno. Posting from home work fine posting from work gives 404's so I suspect my f#cked up basta of a proxy server at work that I need a budget for a replacement for before trashing this one is to blame.

_________________
Mart

- He's chained forever to a world that's departed.....It's not enough, it's not enough - Sorrow by Pink Floyd.
Back to top
View user's profile Send private message
Mart
KiXforms Regular
KiXforms Regular


Joined: 03 Oct 2005
Posts: 57
Location: Rotterdam - Netherlands

PostPosted: Fri Aug 10, 2007 2:58 pm    Post subject: Reply with quote

Shawn wrote:
Its a .NET thing ... the first instance of a .Net app takes forever to launch. Not so bad afterwards. For login scripts (which would always be the first thing to be run) I would stick with classic.


Thanks Shawn.
For a minute I thought is was my crappy kf.net coding (first time using kf.net Embarassed ) but as it turns out it's not my fault.

As to sticking to classic kf for logon scripts I'm in between choices. If the classic kf came as a MSI installer so it could be deployed with a GPO I'd go for it because registering the dll with a start up script for example is not really an option for me.

_________________
Mart

- He's chained forever to a world that's departed.....It's not enough, it's not enough - Sorrow by Pink Floyd.
Back to top
View user's profile Send private message
Les
KiXforms Aficionado
KiXforms Aficionado


Joined: 24 Dec 2003
Posts: 317

PostPosted: Fri Aug 10, 2007 3:34 pm    Post subject: Reply with quote

What sort of performance difference are you seeing between first-run and subsequent runs?

If the PC were already powered up, or if the user wasn't waiting for the C+A+D window to appear, you might be able to preload the needed .NET bits by invoking a small startup script. Later, when the logon script fires, it might go a bit faster.

_________________
The Repro Man
Stealing for a living!
Back to top
View user's profile Send private message
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Fri Aug 10, 2007 3:40 pm    Post subject: Reply with quote

Kixforms.Classic comes with an MSI - its in the zip file. Check-out the development build announcement sticky thread for the link. Never tried installing it thru GPO myself though.
Back to top
View user's profile Send private message
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Fri Aug 10, 2007 3:43 pm    Post subject: Reply with quote

Check-out out this thread about .net startup performance:

Re: .NET Startup Performance, Explain to me what's going on.

I'm going to give the referenced links a read too.
Back to top
View user's profile Send private message
Mart
KiXforms Regular
KiXforms Regular


Joined: 03 Oct 2005
Posts: 57
Location: Rotterdam - Netherlands

PostPosted: Mon Aug 13, 2007 3:37 pm    Post subject: Reply with quote

Les wrote:
What sort of performance difference are you seeing between first-run and subsequent runs?

If the PC were already powered up, or if the user wasn't waiting for the C+A+D window to appear, you might be able to preload the needed .NET bits by invoking a small startup script. Later, when the logon script fires, it might go a bit faster.


A script in kf classic starts almost immediately and one in kf.net takes about two or three seconds.

Starting a small startup script so that the .net stuff is loaded and the login script is not the first .net app to launch might work. I'll look into that.

_________________
Mart

- He's chained forever to a world that's departed.....It's not enough, it's not enough - Sorrow by Pink Floyd.
Back to top
View user's profile Send private message
Mart
KiXforms Regular
KiXforms Regular


Joined: 03 Oct 2005
Posts: 57
Location: Rotterdam - Netherlands

PostPosted: Mon Aug 13, 2007 4:16 pm    Post subject: Reply with quote

Shawn wrote:
Kixforms.Classic comes with an MSI - its in the zip file. Check-out the development build announcement sticky thread for the link. Never tried installing it thru GPO myself though.


Embarassed never noticed the msi. I always just regged the dll and go from there.
Switching to classic is and option but only if all else fails.

_________________
Mart

- He's chained forever to a world that's departed.....It's not enough, it's not enough - Sorrow by Pink Floyd.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    KiXforms Forum Index -> KiXforms.NET Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group